
1 

page 

 

 artisteer.com | page 1  

 



2 

page 

 

 artisteer.com | page 2  

Table of Contents 

Table of Contents ............................................................................................................................................. 2 

What is Artisteer? ............................................................................................................................................. 4 

What’s new in Artisteer 2 .................................................................................................................................. 5 

Product Comparison ......................................................................................................................................... 6 

Quick Start Guide ............................................................................................................................................. 7 

Downloading Artisteer ................................................................................................................................... 7 

System Requirements ................................................................................................................................... 7 

Installing Artisteer .......................................................................................................................................... 8 

Activating the software .................................................................................................................................. 9 

How to work with the Artisteer Interface ......................................................................................................... 10 

Quick Access Toolbar ................................................................................................................................. 11 

Keyboard Accessibility ................................................................................................................................ 11 

Creating a Basic Design.............................................................................................................................. 13 

Design Customization ................................................................................................................................. 14 

Dialog Boxes ............................................................................................................................................... 15 

Color Selector Dialog .................................................................................................................................. 17 

Working with Colors .................................................................................................................................... 18 

Block Structure ............................................................................................................................................ 19 

Navigation Bar ................................................................................................................................................ 23 

1. Ideas ....................................................................................................................................................... 23 

1.1. Creating Your Design ....................................................................................................................... 23 

1.2. Making Adjustments ............................................................................................................................. 23 

Export Design .......................................................................................................................................... 24 

Export Options Dialog ............................................................................................................................. 25 

Export Design Options ............................................................................................................................ 27 

2.1. Colors ............................................................................................................................................... 42 

2.2. Paints................................................................................................................................................ 42 

2.3 Fonts .................................................................................................................................................. 43 

3. Layout ..................................................................................................................................................... 46 

3.1 Page/Column Layout ......................................................................................................................... 47 

3.2 Columns ............................................................................................................................................ 47 

4. Background ............................................................................................................................................. 48 

4.1 Adjust Page Background Options. .................................................................................................... 48 



3 

page 

 

 artisteer.com | page 3  

5. Sheet ....................................................................................................................................................... 50 

5.1 Adjust Sheet Options ......................................................................................................................... 51 

6. Header .................................................................................................................................................... 53 

6.1 Header Layout ................................................................................................................................... 53 

6.2 Background ....................................................................................................................................... 54 

6.3. Foreground Photo ............................................................................................................................ 59 

6.4. Title ................................................................................................................................................... 60 

6.5. Title Style .......................................................................................................................................... 62 

7. Menu ....................................................................................................................................................... 63 

7.1. Menu Styles. ..................................................................................................................................... 63 

7.2. Menu Bar .......................................................................................................................................... 64 

7.3. Item ................................................................................................................................................... 65 

7.4. Sub Item ........................................................................................................................................... 66 

8. Articles .................................................................................................................................................... 67 

8.1. Shape ............................................................................................................................................... 68 

8.2. Text Formatting ................................................................................................................................ 70 

8.3. Other elements ................................................................................................................................. 72 

8.4. Header and Footer ........................................................................................................................... 74 

9. Blocks ...................................................................................................................................................... 75 

9.1. Block Styles. ..................................................................................................................................... 75 

9.2. Block Content ................................................................................................................................... 83 

10. Buttons .................................................................................................................................................. 86 

11. Footer Tab ............................................................................................................................................. 89 

11.1 Footer Styles ................................................................................................................................... 89 

Troubleshooting .............................................................................................................................................. 92 

Glossary .......................................................................................................................................................... 93 



4 

page 

 

 artisteer.com | page 4  

What is Artisteer? 

Artisteer is the first and only Web design automation product that instantly creates fantastic looking website 

and Blog templates. It is a powerful software suite that makes YOU a professional designer of websites, 

WordPress themes, and blog templates. Artisteer lets you create fantastic looking website designs and 

templates in just minutes; without having to know anything about editing graphics or HTML.  

 

With Artisteer YOU immediately become a web design expert; editing and slicing graphics, coding XHTML 

and CSS, and creating CMS templates and WordPress themes - all in minutes and without Photoshop, 

Dreamweaver, or technical skills. 

Use Artisteer to generate cool Web design ideas, adjust the generated designs using many included 

elements, backgrounds, photo objects and buttons, create professional, table-free, cross browser 

compatible and fully compliant HTML and CSS code, and export your design to create great looking Web 

and Blog templates. 

Creating great designs has never been easier! 
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What’s new in Artisteer 2 

Artisteer 2 has a number of exciting new features. The main highlights of this version (as compared to 

version 1) are: 

 Support for creating Joomla templates. 

 Support for creating Drupal themes. 

 Support for creating Visual Studio project templates. 

 Perfectly valid HTML+CSS  

 Typography and font scaling features 

 Footer editing features 

 Support for sheet transparency 

 Support for uploading custom page background images, glares and textures 

 Support for block bullets 

 Keyboard shortcuts for opening and saving files, undo, redo, etc. 

 Internationalization support. Exported Wordpress themes are internationalized and available in 

French, German, Italian and Spanish, with additional languages available from WordPress Website. 

 New “Export Options” dialog that allows specifying template version, tags, author, and manage 

some of the WordPress and Joomla specific options. 

 An option for custom watermarks if you are creating temporary templates for review by your 

customers and want to use our built in trial protection mechanism. 

 Improved Export Dialog with the ability to specify template name and path as well as export 

template to .zip file. 
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Product Comparison 

Artisteer Standard Edition vs. Home and Academic Edition. 

Version 
Home & Academic 

Edition 

Standard 

Edition 

Free upgrades for 1 year   

Design Suggestions   

Design Features   

Export as XHTML+CSS   

Export as Wordpress Theme   

Export as Joomla Template    

Export as Drupal Theme    

Export as ASP.NET Application    

Export to CodeCharge Studio    

Custom Value Dialogs (screenshot)    

Library of Textures, Glares and Gradients partial (75%)  

Number of Color and Font Schemes 50+ 70+ 

Number of Photo Objects 200+ 300+ 

 

 

http://www.artisteer.com/media/p4/images/options.png
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Quick Start Guide 

Downloading Artisteer 

You can download the Artisteer installation file from the official Artisteer Web site at 

http://www.artisteer.com. The software is provided with a free trial period that allows you to evaluate the 

product prior to purchasing the software. During this period of time, Artisteer is fully functional and has all its 

features available for testing. The only restriction is that all the templates and images generated with 

Artisteer will have watermarks embedded in them until the product is activated. The trial period is unlimited 

so you can activate the software at any time you wish and activation instructions are provided in the 

Activating the Software chapter of this manual. 

System Requirements 

This section describes the minimum system requirements for the Artisteer software.  

Development Environment: 

 Intel or AMD processor 1500 MHz or higher 

 100 Mb free disk space 

 512 Mb RAM or higher 

 Microsoft Windows 2000, XP, Vista 

 Microsoft .NET Framework 2.0+. This framework can be obtained from the Microsoft website at: 

http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-

aab15c5e04f5&displaylang=en 

Browsers supported: 

 Internet Explorer 6+ 

 Firefox 2+ 

 Opera 9+ 

 Safari 1+ 

 Google Chrome 1+ 

http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en
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Technologies supported: 

 CodeCharge Studio 4 

 WordPress (2.5-2.7) content management system  

 Joomla 1.5 content management system 

 Drupal (5.x, 6.x) content management system 

Standards supported: 

 XHTML 1.0 Transitional 

 CSS 2 

 Section508 (partially) 

 PNG with transparency 

Installing Artisteer 

This chapter describes how to install Artisteer on your computer.  

Note: Before you proceed please make sure that your computer meets the requirements listed in the 

System Requirements chapter. 

1. Log into Windows as a Power User, or assume the Primary Administrator role.  

2. Double-click the installation file called ArtisteerInstall.exe. This will launch a standard installation 

process.  

3. Select the language that you’d like to use during the installation and then click the Next button. 

4. Follow the instructions provided by the Installation Wizard. 

5. Carefully read the License Agreement. If you accept its terms, check "I Accept the terms of the License 

Agreement" option and proceed to the next step. If you do not agree, you can quit the installation at this 

point. Please feel free to contact us if there are any problems or concerns with the agreement so that 

we may correct any problems that may exist. 

6. Select the destination folder where you want the product installed. 

7. Indicate whether you want to create shortcut icons on the Desktop, Quick Launch panel, or both. 

8. Click the Install button to start the installation. 

9. Click the Finish button when the installation is complete. 
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Activating the software 

After you’ve purchased Artisteer you will receive a Serial Number to be used to activate the software. The 

activation removes the watermarks added to the generated templates by the trial version. 

To activate the product click on the Palette icon to open Artisteer Activation dialog and enter your serial 

number in the first box. If your computer is connected to the internet, you can check "Auto-activation 

through the internet" option and click the Activate button. This will simplify the activation process. 

If you work off-line or do not wish to use the Auto-activation method, you can use the following link to obtain 

the activation key from any other computer connected to the web: 

http://www.artisteer.com/?p=a 

In this case, uncheck the "Auto-activation through the internet" option and enter the obtained activation key 

directly in the Activation Key box. 

 

You will need to restart Artisteer after you successfully complete the activation process. 

http://www.artisteer.com/?p=a
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How to work with the Artisteer Interface 

The Artisteer interface is quite simple to learn. There are several main items: Main Menu, Quick Access 

Menu, Tabbed Navigation Bar and Design Preview (highlighted on the image below). 

Main Menu contains basic file commands, recent documents and other standard items for the File menu. 

Quick Access Menu contains Undo, Redo, Save and Open shortcuts. 

Navigation Bar contains all available editing tools.  

Design Preview lets you see how your design will look. All links and buttons in Design Preview are non-

clickable. 

 

Quick Access Toolbar Main Menu Navigation Bar Design Preview 
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Quick Access Toolbar 

The Quick Access Toolbar is a customizable toolbar that provides the ability to create one-click shortcuts to 

frequently used commands and quickly perform the most common tasks.  

By default, the Artisteer Quick Access Toolbar contains the Open, Save, Undo, Redo and Export buttons, 

but you can customize the content of the toolbar by adding or removing items as you like.  

To add a new item, right click on the desired command button in the Navigation Bar and select the "Add to 

Quick Access Toolbar" option. 

To remove an item from the Quick Access Toolbar, you can right-click on the button and select the 

"Remove from Quick Access Toolbar" option. 

Note: Not all the commands located in the Navigation Bar can be added to the Quick Access Toolbar. For 

these commands the "Add to Quick Access Toolbar" option in the right click menu is disabled. 

By default the Quick Access Toolbar is located above the Navigation Bar. To place it beneath the 

Navigation Bar, click the small arrow button on the right end of the toolbar (or simply right-click within the 

toolbar or ribbon area) and select the “Show Quick Access Toolbar below the Ribbon” option from the drop-

down menu. 

Keyboard Accessibility 

Many options available in Artisteer can be accessed using keyboard keys instead of the mouse. There is a 

set of combination keys provided to map to particular commands on the Navigation Bar and Quick Access 

Toolbar. Press the Alt key to see the Key Tip badges pop up for each tab.  
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Pressing the key shown in some particular Key Tip badge switches the Navigator to that tab. For example, 

you can press A to switch to the Articles tab, M to switch to the Menu tab, and so forth.  

Let’s assume we want to navigate to the Ideas tab. 

Once the desired tab is opened, you will see another set of Key Tips displayed next to their respective 

commands, as shown below:  

 

Pressing those key combinations will execute the command just as if you had clicked the corresponding 

button with the mouse. For example, pressing T on the Ideas tab will display a list of template options; S 

and U keys typed quickly one after another will call the “Suggest Design” option, and so on. 
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Creating a Basic Design 

Creating a design with Artisteer is as easy as 1-2-3: 

 

In most cases, nearly everything you need to do can be started by clicking on the Suggest Design button. 

This creates a random design that you can work on or you can click it again to see another suggested 

design. 

1. Suggest Design 

is a tool to find a basic 

theme idea and a great 

place to start from.  

 

2. When you find a 

good design idea, you 

may want to adjust some 

design elements like 

colors, fonts or page 

background separately. 

The corresponding 

“Suggest …” buttons 

can help you with this. 

 

3. Click Export to 

save the created design 

as a WordPress theme, 

HTML template, or any 

other format you like. 

 



14 

page 

 

 artisteer.com | page 14  

Design Customization 

Artisteer is a powerful tool with great customization capabilities. After you find a good design idea, you may 

go into a specific tab and adjust the design to match your needs.  On each tab, there are several options for 

customizing specific elements. 

Note: Some options may not be available depending on the settings and layout choices you have made in 

other areas. 

That is not all! When using Artisteer Standard Edition if you can’t find the option you want in a specific list 

then click on “More…” to get full customization capabilities: 

Here is an example of how this works using the Sheet tab: 

 

Note: the detailed option adjustment dialogs are not available in Artisteer Home & Academic Edition. 

There are even 

more options 

here… 
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Dialog Boxes 

Many options and settings are included in the dialog boxes.  These can be accessed by clicking the small 

arrow button  to the right of the group caption.  

 

The user interface for a typical dialog box includes the following parts: 

 Dialog caption that indicates what kind of options are available in the dialog 

 The list of option groups located in the left pane of the dialog box. Click on the group to expand the 

options. 

 Options and settings available for the selected group. 

 Preview checkbox to view the results of the setting automatically as they are changed. 

 Preview button to display the results of the settings on the page. 

 OK button to apply the settings and close the dialog box. 

 Cancel button to discard the changes and close the dialog box. 

An example of a dialog box is provided in the picture below. 
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Most of the dialog boxes contain settings that can be changed using slider bars. Usually, these are settings 

for the width, height, opacity, transparency, and other range values. To make changes, position the pointer 

over the slider and drag it to the right or left to increase or decrease a specific option’s value. The selected 

value will be displayed in the box next to the slider bar. You can also enter the desired value directly into 

this textbox. 

Use the "Preview" button or "Preview" option, available at the bottom of the dialog window, to view the 

changes.  

If the "Preview" checkbox is ticked, the changes will be immediately displayed on the page as you drag the 

slider. If you type the value directly in the option box, click outside the box to have the value applied to the 

page. If the "Preview" option is unchecked, press the Preview button to see the changes on-screen. The 

use of the Preview feature will help you easily achieve the desired look of your page. 

Finally click the OK or Cancel buttons to commit to or discard your changes.
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Color Selector Dialog 

The Color Selector dialog box is displayed when you select the "More Colors…" button in one of the color 

option dialog boxes.  

    

The Color Selector dialog box lets you select the desired color and adjust the hue, saturation, and 

brightness of the color.  

There are Luminosity and Hue tabs available in the dialog box. Both tabs have a color selection area (color 

palette) where you can move a slider until you achieve the perfect color.  

On the Luminosity tab, there is a special luminosity slider. This slider lets you increase or decrease the 

brightness of the color from zero at the bottom to 100 at the top. 

With the luminosity selected, you can go to the color palette and drag a small circle picker horizontally and 

vertically to change the hue and saturation of the color respectively. 

The Hue tab contains a separate Hue adjustment slider. Moving it all the way from red (at the bottom) 

through orange, yellow, green, blue up to purple allows you to select the desired hue of the color.  

Having the hue selected, you may also move a palette color picker from left to right and from top to bottom 

to additionally set the saturation and luminosity values of the color. Saturation can vary from 0% (completely 

unsaturated) to 100% (completely saturated, pure color). Luminosity ranges from 0 (black) to 100% (white). 
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The values displayed in the right set of boxes will change to indicate the exact color settings. These values 

can also be changed manually or directly in the text boxes. It may be convenient when you copy the exact 

color value from some other graphic software and want to use it in Artisteer.  

Property Description 

Hue The hue value of the color ranged from 0° to 360°. 

Sat The saturation of the color ranged from 0% (completely unsaturated) to 

100% (fully saturated). 

Lum The luminosity of the color measured in percentage from 0 (black) to 

100% (white). 

Red The decimal value of the red shades. 

Green The decimal value of the green shades. 

Blue The decimal value of the blue shades. 

Hex A hexadecimal color code (usually used in HTML code). 

The "Preview" option makes it possible to see the page with the selected color applied to it. 

Ok and Cancel buttons allow you to submit or discard the changes made. 

Working with Colors 

The colors on computer monitors are made up of varying amounts of red, green and blue base colors. 

Depending on how much you take from each base color, you can create any of the colors which a monitor 

can display. For example; a mix of red and green produces a yellow color, a mix of red and blue produces a 

magenta color and so forth. Mixing all three base colors with full intensity produces white while the absence 

of all the components returns black. 

The values for red, green, and blue base colors are usually specified using a scale from 0 to 255 (decimal), 

where 255 represents 100% intensity of the color. 

RGB is a convenient color model for computer graphics because the human visual system works in a 

similar way. However, human perception does not see colors as triplets of numbers: red, green and blue. 

Instead it is quite convenient to describe colors as made up of hue, saturation and lightness (or luminosity). 

This HSL scheme defines colors more naturally and can be visualized as a cylinder whose central axis 

ranges from black at the bottom to white at the top with neutral colors between them, where angle around 
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the axis corresponds to “hue”, distance from the axis corresponds to “saturation”, and distance along the 

axis corresponds to “lightness”, or “luminosity”.  

 

Hue specifies a pure, spectral color. It is measured as a location on the color wheel, expressed as a degree 

between 0° and 360°. In common use, hue is identified by the name of the color such as red, orange, or 

green. 

 

Hue Color 

0 red 

1 yellow 

2 green 

3 cyan 

4 blue 

5 magenta 

6 red 

Saturation is the purity of the color. It represents the amount of grey in proportion to the hue. This is 

measured as a percentage from 0% (grey with no hue at all) to 100% (fully saturated color). On the 

standard color wheel, saturation increases from the center to the edge.  

Luminosity (Lightness): is the relative lightness or darkness of the color, usually measured as a 

percentage from 0% (black) to 100% (white). 

Artisteer allows you to work with both HSL and RGB color schemes. The desired color can be specified in 

the Color Selector dialog box. 

Block Structure 

Blocks are an important part of Artisteer's web designs that are compatible with all modern web browsers, 

including Microsoft® Internet Explorer® 6. All of Artisteer's layout elements use blocks to create an optimal 

layout structure. In Artisteer, the block is used as a universal content container that is easily resized 

properly in any direction.  
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The application of blocks in Artisteer not only solves this complicated task, but also creates an optimal 

structure.  

Here is an example of Artisteer's use of blocks:  

 

The background and the block content sit on different levels. The Lower Level, or Background, uses 

multiple elements to work around the CSS2 limitation of only one background image per element. The 

Upper level sits on top of the Lower Level and contains the actual Content.  
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The levels consist of the following objects.  

The Lower Level:  

 1, 3, 7, 9 - the segments of the corner image; 

 2, 4, 6, 8 - the segments of the side image; 

 5 - the central background image. 

The Upper Level:  

 10 - the text with the indentation. 

The following outlines the HTML structure.  

<div class="box"> 

 <div class="box-tl">1</div> 

 <div class="box-tc">2</div> 

 <div class="box-tr">3</div> 

 <div class="box-cl">4</div> 

 <div class="box-cc">5</div> 

 <div class="box-cr">6</div> 

 <div class="box-bl">7</div> 

 <div class="box-bc">8</div> 

 <div class="box-br">9</div> 

 <div class="box-body">10</div> 

</div> 

The margins in Object 10 include the corner radius and shadow sizes to display the Content properly within 

the borders and shadow of the Background. When the radius is not specified, the perception of margins is 

created by the actual graphic border and shadow images in the background.  

 

The Upper Level is fluid and resizable in any direction, and the size of the Lower Level always corresponds 

with the size of the Upper Level.  

 

Regardless of the sizes of objects 1, 2, 3, 4, 6, 7, 8, and 9 Object 5 automatically resizes itself to take up 

the rest of the space between them.  
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Please note that if the background color is set for Object 10 (Upper Level) and the background color is not 

set for object 5, the Lower Level will be fully overlapped. The Lower Level elements, such as round corners, 

borders, and shadows will not be visible as they will be covered by the Upper Level. 
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Navigation Bar 

Let’s have a closer look at the Navigation bar. It is divided into eleven different distinct categories and used 

to customize your design.  Moving from left to right, we begin with the overall idea and layout to the site.  As 

we move to the right, we become focused on specific parts of the site such as blocks and buttons. 

 

1. Ideas 

The Ideas tab is a great way to quickly envision your Website design right before your eyes.  

 

1.1. Creating Your Design 

Let Artisteer create your design for you. The Suggest design feature is best used at the beginning.  It allows 

you to see the various designs available and helps you determine which styles and themes you like. 

 

1.2. Making Adjustments 

You are able to make adjustments to many individual components when brainstorming ideas for your web 

design. 
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Sometimes, the font doesn’t match the layout of the site or the buttons don’t match the navigation.   By 

making these adjustments, you can get closer to the look that you want to achieve. 

Export Design 

Once you have settled on the basic look of your site, you can export it as a design or template that is 

compatible with the type of blog, CMS or application that you want to use. 

 

There are three steps that need to be followed to export the design: 

1. First, select a template which will be applied and used when viewing the page in Artisteer. Currently 

the following templates are available: website design, WordPress, Joomla, Drupal, Visual Studio 

and CodeCharge Studio.  

2. Next, tell Artisteer what export option you want to use when generating the selected template. 

Choose the desired Export Design option to export and save your design as individual style files. 

3. In the Export Dialog, specify the desired template name and the folder to export your template files 

to. If necessary, compress the template folder by using "Export as a ZIP archive" option. 
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Option Description 

Name Identifies the name of your theme. It is recommended that the name 

should conform to the naming conventions of the CMS or other location 

you are exporting to. 

Path Indicates the path to the folder where the exported files should be placed. 

Export as a folder When the template is exported, a folder with the specified name 

containing all the theme files is created in the specified location.  

Export as a ZIP archive When the template is exported, a zip archive containing all the theme files 

is created in the specified location. 

Export Options Dialog 

The Export Options dialog box appears when you select Export > "Export Options..." from the Main Menu. It 

can also be accessed by using the Export > "Export Options" command on the Ideas tab or on the Quick 

Access Toolbar. The dialog provides a set of options for exporting templates from Artisteer.  

The available options are explained below. Most of them are optional and no value is assigned when a field 

is left empty. 
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Properties Tab 

The properties tab is used to describe the information to be used by Artisteer to generate the style sheet, 

header, and the metadata information for the theme. This information will be further used by CMS, if your 

CMS supports such functionality. 

Property Description 

Author Name Identifies the name of the person or organization creating the design. 

Author URL Provides the reference to the author's website 

Show Author in Footer When checked, the above-defined author name will be displayed in the 

page footer. 

Template Version Identifies the version number of the template. 

Template URL Specifies the location of the template on the web. 

Tags Specifies the keywords associated with the theme. 

Description Provides additional information about the theme. 

WordPress Tab 

The WordPress tab contains a Home Page menu item setting which specifies whether Artisteer should 

create a special menu item pointing to the homepage (front page) of the website. 

Property Description 

Visible Item If this option is checked, Artisteer creates a special Home Page menu item 

which is highlighted when the website’s front page is displayed in a 

browser. If the front page is not set, this menu item points to the list of 

posts. If the "Visible Item” option is unchecked, no menu items are created 

by Artisteer. The whole menu is built from the list of WordPress pages. If 

the front page is specified in WordPress settings, you will see the menu 

item that corresponds to that page added and highlighted in the menu. If 

the front page is not set, no menu item is highlighted by default when the 

list of posts is displayed in a browser. 

Item Name Specifies the caption of the menu item pointing to the home page. 
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Joomla Tab 

Property Description 

Top menu/Position name Specify the module position where you place site menu.  Exported 

template will have a position with the specified name created especially 

for the top menu. 

Watermark Tab 

Property Description 

Show Watermark If checked, the watermark text will be repeated throughout the page. 

Watermark Text A text to be displayed across the page when the "Show Watermark" 

option is enabled. 

Export Design Options 

Now let us consider every export option in a little more detail. 

Icon Option Description 

Content Management System Theme 

 

WordPress The WordPress template option is provided for those who 

create designs for WordPress websites. After selecting this 

template from the Template list, you have options to export 

the design as an HTML template or a WordPress theme. 

 

Joomla The Joomla template option is provided for those who create 

Joomla website designs. Selecting this option provides the 

possibility of exporting your design as an HTML or Joomla 

template. 

 

Drupal The Drupal template option is provided for those who work 

with Drupal CMS. Selecting this option allows you to export 

your design as an HTML template or Drupal theme. 

HTML Template 

 

Company Homepage  This template can be selected if you don’t use any particular 

CMS (content management system) but want to create a 

professional CSS design for your website.  
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Web Developer Template 

 

ASP.NET Application The ASP.NET Application option is provided for .NET 

developers creating websites in MS Visual Studio. The design 

can be exported as an HTML template or as a Visual Studio 

C# project. 

 

CodeCharge Studio The CodeCharge Studio template option is provided for 

developers and designers who use the CodeCharge Studio 

development tool for creating web applications. After selecting 

this template from the Template list, you have options to 

export the design as an HTML template or as a CodeCharge 

Studio Project. 

Exporting a design as a WordPress theme: 

To export a design as a WordPress theme that can be applied to the existing WordPress installation, follow 

these steps: 

1. Select Template > WordPress template. 

2. Select Export >”WordPress Theme" option. 

3. Specify the desired name and path to the folder to export your template files to. If necessary, you 

can compress the template folder by using "Export as a ZIP archive" option. 

After the export, you will obtain WordPress-specific theme files that can be located in the theme folder on 

the server and can be easily applied to the WordPress websites. The path to the theme folder in the 

WordPress system usually looks like: WordPressFolder\wp-content\themes\ThemeName. Now you can 

simply upload the exported theme files into that folder.  

To apply the new theme to your website, login to the WordPress Administration Panel, navigate to the 

Presentation tab (WordPress version 2.6) or to the Appearance > Theme (WordPress version 2.7) and 

activate this theme. 

The generated WordPress themes are widget ready and compatible with WordPress version 2.5 and 

higher. 
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Tips and Tricks:  

Installing WordPress Themes 

1. Access your Web server using an FTP client or Web server administration tools. 

2. Create a folder for your specific theme under "wp-content/themes" folder within WordPress 

installation. 

For example: <WordPressFolder>\wp-content\themes\<YourThemeName> 

3. Copy or upload theme files exported from Artisteer into the newly created <YourThemeName> 

folder. 

4. Login to your WordPress administration panel and select Design -> Themes. 

5. In the 'Available Themes' section click on your theme title or screenshot, then click the 'Activate 

Theme' link to activate it. 

For more information please refer to the official WordPress documentation: 

http://codex.wordpress.org/Using_Themes#Adding_New_Themes. 

WordPress theme localization 

When exporting themes, Artisteer automatically includes several language files obtained from the 

WordPress Website at: http://codex.wordpress.org/WordPress_Localization. Specifically, French, German, 

Italian and Spanish translations are exported by Artisteer in the WordPress compliant file naming format. 

<country>_<LANG>.mo. For example, a German language file is: de_DE.mo. 

To include different or additional language support in your WordPress theme, please find and copy the 

desired language files into your specific WordPress theme folder. You can find the additional language files 

in your default theme folder "<WordPressFolder>\wp-content\themes\default", or on the WordPress Website 

at http://codex.wordpress.org/WordPress_Localization. To select a different language than your current 

WordPress language, change the "define" function in the wp-config.php file. For example: 

define('WPLANG', 'de_DE') 

To edit translations for your language, please download and install the Code styling Localization plug-in 

from http://wordpress.org/extend/plugins/codestyling-localization/. Then in WordPress administration, select 

Manage -> Localization. 

http://codex.wordpress.org/Using_Themes#Adding_New_Themes
http://codex.wordpress.org/WordPress_Localization
http://codex.wordpress.org/WordPress_Localization
http://wordpress.org/extend/plugins/codestyling-localization/
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Installing additional language support 

To include a different or additional language support in your Worpdress theme please find and copy the 

desired language files into your specific Wordpress theme folder.  

You can find the additional language files in your default theme folder 

"<WordPressFolder>\wp-content\themes\default", 

or on the Wordpress Website at http://codex.wordpress.org/WordPress_Localization.  

To select a different language than your current Wordpress language, change the "define" function in the 

wp-config.php file, for example: define('WPLANG', 'de_DE').  

Editing translations 

To edit translations for your language please download and install Codestyling Localization plug-in from 

http://wordpress.org/extend/plugins/codestyling-localization/.  

Then in WordPress administration select Manage -> Localization.  

Customizing the Footer 

To customize the template footer via WordPress 2.6+ administration:  

o go to Administration -> Appearance -> Footer 
o edit the HTML 

Please note that the footer content will be placed within the Paragraph container (<p>).  

 

http://codex.wordpress.org/WordPress_Localization
http://wordpress.org/extend/plugins/codestyling-localization/
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Exporting a design as a Joomla theme: 

To export your design as a Joomla template, follow the steps below: 

1. Select Template > Joomla option. 

2. Use Export > “Joomla Template”. 

3. Specify the name and select the folder you want to export the template files to.  Alternatively, you 

can choose to compress the template folder by using the "Export as a ZIP archive" option. 

After the export, you will obtain a set of Joomla-specific files that can be located in the theme folder on the 

server and easily applied to the Joomla websites. The path to the theme folder in the Joomla system usually 

looks like this: JoomlaFolder\templates\ThemeName. You can simply copy/upload the exported theme files 

into that folder.  

If your theme is exported as a ZIP archive, log into the back-end of your Joomla installation, go to 

Extensions > Install/Uninstall, choose "Upload Package File" option in the "Extension Manager", type the 

path or click the "Browse..." button to select your zip file, and click the "Upload File & Install" button to 

upload and install the theme. Once the theme is successfully installed, you can activate it by selecting 

Extensions > Template Manager from the drop-down menu and assigning your template as the Default 

Template for the website. 

Note: The generated Joomla themes are compatible with Joomla version 1.5 and higher. 

Tips and Tricks: 

Installing Joomla Template 

To install an exported and zipped template via the Joomla administration panel please do the following: 

1. Go to Joomla Administrator (www.your-site.com/administrator) -> Extensions -> Install/Uninstall 

2. In the "Extension Manager" choose the first option "Upload Package File". 

3. Click the "Browse..." button to select the zip file from your computer. 

4. Click the "Upload File & Install" button. 

For more information please visit http://docs.joomla.org/How_to_install_templates. 

http://docs.joomla.org/How_to_install_templates
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Joomla localization 

Joomla provides an internationalization feature and currently supports 50 world languages. The language 

packages are available for download at: http://joomlacode.org/gf/project/jtranslation/frs/ 

Joomla uses three language packages: one for the front end, one for the administrator and one for 

installation. It is not required to use all three. Feel free to download only the necessary packages and 

customize the language settings to serve your needs. 

If there are no packages for your language, you can create them manually by following the instructions 

provided in the Joomla documentation here: http://docs.joomla.org/How_to_create_a_language_pack 

Utilizing Menus 

Please use the following steps to utilize menu style designed with Artisteer: 

1. Go to Joomla Administrator (www.your-site.com/administrator) -> Extensions -> Module Manager 

2. Open an existing menu or create a new one and place it into the "user3" position. 

NOTE: the "user3" position can contain only a single menu, or none. 

For more information please visit http://docs.joomla.org/Screen.modules.15. 

Apply Artisteer style to Joomla menu 

To apply Artisteer menu style, you should locate your menu in the module position specified under the 

Export Options > Joomla > Top menu/Position name in Artisteer. For this, after the export go to Joomla 

Extensions > Module Manager, select the Menu (e.g. Top Menu), click the Edit icon on the toolbar > Details 

section, and select the specified position in the Position list box. 

Multilevel Menu in Joomla 

It takes three steps to create a multilevel menu in Joomla: 

1. Activate a multilevel menu for your template in Artisteer (Menu > Sub item > Levels > Multilevel 

option). 

2. Locate your menu in the user3 module position in Joomla Administrator. 

http://joomlacode.org/gf/project/jtranslation/frs/
http://docs.joomla.org/How_to_create_a_language_pack
http://docs.joomla.org/Screen.modules.15
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3. Go to Joomla Extensions > Module Manager, select the Menu (e.g. Top Menu), click the Edit icon 

on the toolbar, and set "Always show sub-menu Items" in the Module Parameters dialog to "Yes". If 

necessary, you can also specify the number of sublevels using "Start Level" and "End Level" 

options. 

Customizing the Footer 

To customize the template footer via Joomla administration place one or multiple modules into the 

"copyright" position. This will replace the default copyright text included in the template footer with the new 

content provided by the module. 

Here are sample steps to configure custom footer: 

1. Go to Joomla Administrator (www.your-site.com/administrator) -> Extensions -> Module Manager. 

2. Click "New", select "Custom HTML", then select "Next". 

3. In the module properties specify: 

 Title - Show Title: No 

 Position: copyright 

 Custom Output: (the desired footer content) 

   4. Save your changes. 

You can now use the newly created module for further footer customizations without utilizing additional 

modules. 
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Joomla Positions 
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Joomla Module Style (in Artisteer 2.2) 

The Default Position Style is applied to all modules located within a specific position. 

If you want to change the style of a particular module, please follow the steps below: 

1. Log into your Joomla Administration and go to Extensions -> Module Manager. 

2. Select the module you want to edit. 

3. Go to Module Parameters and specify a suffix of your choice in the Module Class Suffix parameter 

box. You can use one of the available suffixes: art-article, art-block or art-nostyle. 

 

 

If you specify another suffix (not available in the template) the Default Position Style will be applied to 

your module. 

4. Save the module settings. 

Exporting a design as a Drupal theme: 

To export a design as a Drupal theme, follow these steps: 

1. Select Template > Drupal. 

2. Use Export > “Drupal Theme” option. 

3. Specify the template name and select the folder you want to export the template files to.  If 

necessary, apply zip compression using "Export as a ZIP archive" option. 

After the export, you will obtain a set of Drupal-specific theme files that can be located in the theme folder 

on the server and can easily be applied to the Drupal websites. The path to the theme folder in the Drupal 

system usually looks like: DrupalFolder\themes\ThemeName. You will need to upload the exported theme 

files to that folder. If your theme is exported as a ZIP archive, extract the archive into the "themes" folder on 

server. After that, you can activate your theme in the Drupal Administration. For this, log into the 

administration area, navigate to Administer > Site Building > Themes, check the "Enabled" box as well as 

the "Default" radio button next to your template, and click the "Save configuration" button. 

http://www.artisteer.com/?p=news
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Tips and tricks: 

Installing Drupal Themes 

1. Access your Web server using an FTP client or Web server administration tools. 
2. Create a folder for your specific theme under "<YourSiteFolder>/themes/" folder within Drupal 

installation. 
For example: <YourSiteFolder>/themes/<MyNewTheme> 

3. Copy or upload theme files exported from Artisteer into the newly created <MyNewTheme> folder. 
4. Login to your Drupal Administer. 
5. Go to Drupal Administer -> Site Building -> Themes 

(www.YourSite.com/?q=admin/build/themes) 
6. Select your newly uploaded theme from the list of available themes for your site. 
7. Click the "Save configuration" button to save your changes. 

For more information please visit: http://drupal.org/node/456. 

Naming standards 

Use only letters (preferable lowercase), numbers, and underscores in the theme name. No special 

characters, spaces or hyphens are allowed. If you work with Drupal version 5, be sure not to rename your 

template folder after the export. Otherwise, some functions will be undeclared and the design will look 

corrupted. 

Drupal Localization  

The localization feature is described in the Drupal documentation here: http://drupal.org/node/133977. 

Utilizing Menus 

Please use the following steps to utilize menu style designed with Artisteer:  

1. Go to Drupal Administer -> Site Building -> Menus (www.YourSite.com/?q=admin/build/menu) 
2. Edit an existing menu or create a new one. 
3. Go to Drupal Administer -> Site Building -> Blocks (www.YourSite.com/?q=admin/build/block) 
4. Place menu into the "Menu" region.  

NOTE: the "Menu" region can contain only a single menu, or none.  

 

For more information please visit http://drupal.org/node/102338. 

http://drupal.org/node/456
http://drupal.org/node/133977
http://drupal.org/node/102338
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Customizing the Footer 

To customize the theme footer via Drupal Administer place one or multiple blocks into the "Copyright" 

region.  Here are sample steps to configure custom footer:  

1. Go to Drupal Administer -> Site configuration -> Site information (www.your-
site.com/?q=admin/settings/site-information) 

2. Edit the Footer message field. 
3. Save your changes. 

Drupal Regions 
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Exporting a design as a DotNetNuke Skin: 

To export a design as a DotNetNuke Skin, follow these steps: 

1. Select Template > DotNetNuke Skin. 

2. Use Export > “DotNetNuke Skin” option. 

3. Specify the template name and select the folder you want to export the template files to.  If 

necessary, apply zip compression using "Export as a ZIP archive" option. 

Please note that the skin pack contains ArtMenu.zip, which is a menu module. 

4. In the DNN Administration (Admin -> Skins) choose the "Upload Skin" option. On the following 

screen, click the "Browse" button, which will prompt you to find and select the zip file that you 

created earlier. Next, click the "Install Skin Package" link. 

5. To install the menu module, go to Module Definitions (Host -> Module Definitions) and select "Install 

New Module". You will then be prompted to find and select the ArtMenu.zip on your computer. 

Finally, click the "Install New Module" link. 

Tips and tricks: 

Installing DotNetNuke Skins and Containers 

1. Login to your DotNetNuke website as an Administrator. 
2. Go to Admin -> Skins/Host -> Skins. 
3. Select the "Upload Skin" option. 
4. Browse for the exported skin file (<ExportedSkinName>.zip), then click the "Install Skin Package" 

link. 
5. Go to the Page Settings, in the Advanced Settings section please select Page Skin: 

<ExportedSkinName - page>. 
6. Click the Update link. 

Installing Menu Module 

1. Login to your DotNetNuke Administration. 
2. Go to Host -> Module Definition. 
3. Select the "Install New Module" option. 
4. Browse for the ArtMenuSO.zip file, and then click the "Install New Module" link. 

Utilizing Menus 

Use the following code to display menu: <dnn:ARTMENU ID="ArtMenu1" runat="server" />.  

Installing Skins in DotNetNuke 5.0 

1. Login to your DotNetNuke Administration/Host. 
2. Go to Extensions -> Install Extension Wizard. 
3. Browse to the skin file (<ExportedSkinName>.zip) on your local drive. 
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4. Follow the wizard steps until the skin is installed. 

DotNetNuke Places 

 

Exporting a design as an HTML template 

1. Select any template from the Template list. 

2. Select Export > “HTML”.  

3. Specify the desired name and the destination folder where your HTML template is to be created. 

Alternatively, you can compress the template folder to .zip format using "Export as a ZIP archive" 

option. 

The resulting template will contain markup, styles, and graphics that are necessary to apply the design to 

any web page.  
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Exporting a design as an ASP.NET Project 

To export a design as an ASP.NET project that can be later opened in Visual Studio, you should take the 

following steps: 

1. Select Template > ASP.NET Application option. 

2. Use Export > "Visual Studio C# Project". 

3. Specify the template name and select the folder to store the template files.  If necessary, apply zip 

compression using "Export as a ZIP archive" option. 

When the export is completed, a new C# project will be created in the specified location.  Open it in Visual 

Studio using the File > Open Website option and examine the files created. You will see: 

 Master Page that defines a site's overall layout and contains a set of content placeholders such as 

HeaderContentPlaceHolder, TitleContentPlaceHolder, SheetContentPlaceHolder, etc.  

 Content Page called Default.aspx that has several content blocks and default pages 

(DefaultHeader, DefaultMenu, and DefaultSidebar1) included into it. This page is generated as an 

example for you to see how a finished content page may look like.  

 CSS files that define the design of the pages. 

 A set of other files necessary for the Visual Studio project. 

Feel free to modify the project files the way you want and enjoy! 

Exporting a design as a CodeCharge Studio Project 

To create a design that can be applied to CodeCharge Studio projects, the following steps should be 

performed: 

 Select Template > CodeCharge Studio template. 

 Select Export Design > "CodeCharge Studio Project" option. 

 Browse to the folder where you want to locate the CodeCharge Studio project and click OK to 

export the files. 

When the export is completed, a new CodeCharge Studio project will be created in the specified location. 

The following pages will be added to the project: 
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 PageTemplate 

 Header 

 Footer   

 Main 

 About 

PageTemplate is an essential page that will be used as a basis for creating all the new pages within the 

CodeCharge Studio project. This functionality is achieved using the Project Settings > General > New Page 

Template option. PageTemplate includes the header and footer pages that are used to add page 

background, sheet, header, and menu styles to the pages. Thus, all the newly created CodeCharge Studio 

pages will have page background, sheet, header, and menu styles automatically applied to them.  

However the Artisteer-generated styles cannot be automatically applied to CodeCharge Studio forms, 

buttons, and other blocks on the page. 

To add style to these components you can consider one of the following solutions: 

 Open the CodeCharge Studio Style Builder (Tools >Styles) and add a new style that looks similar to 

the style generated by Artisteer. Use this new style for CodeCharge Studio forms and controls. 

 Modify a CodeCharge Studio page template to add the Artisteer styles manually. In that case, do 

not select any style when creating forms and controls in CCS. Then switch to HTML mode and 

modify your page template manually, adding the Artisteer classes and the necessary html tags. A 

sample html code is provided on the Main page so you can review it and modify CodeCharge 

Studio page templates accordingly.  

The example code below demonstrates how to apply the Artisteer-generated styles to a Record form on 

CodeCharge Studio page. The unchanged HTML code is shown in black, the removed code lines are 

crossed out and highlighted in red, and the lines added to the code are highlighted in blue color. 

 



42 

page 

 

 artisteer.com | page 42  

2. Colors & Fonts 

The Color & Fonts tab provides the ability to change the colors and fonts of the template. 

 

2.1. Colors  

To change the site theme, select a theme from a variety of available color themes. Further, the individual 

colors can be changed. Having chosen the colors, you may refine them by adjusting the overall contrast of 

the colors. 

2.2. Paints  

In this block you have the ability to adjust the color theme. You can select one of the predefined schemes or 

customize the color theme by selecting the desired colors. 

 

Clicking on the “Adjust options…” will open the list of the available color options: 

 Luminosity 

 Saturation 
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 Enter the values or drag the sliders to the right or left to increase or decrease the option values.  

 

Properties: 

Adjust Color Options 

 

Luminosity 

Sets colors luminosity. Luminosity refers to the whiteness or intensity of a 

color. Luminosity for any one color will range from pure white through to black. 

The supported values are from -100% to 100%, where 100% and -100% refer 

to the highest and lowest of the RGB components. 

 

Saturation 

Sets color saturation. Saturation refers to the amount of grey in a color, and 

determines how vivid it is. The supported values are from -100% to 100%, 

where 100% means a large amount of the grey.  

2.3 Fonts 

Select from a wide variety of font themes to match the overall look and content of the site. 

 

The fonts section includes the following functions: 

 Font Sets 

 Typography 

 Font Scale 
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Font Sets allows you to change the text and heading fonts. You can choose one of our standard font sets 

or create your own font scheme. Just click on the Edit Font Set… button in the Font Sets list. 

Typography allows you to select one of our typography styles or create your own style design. Just click 

on the Edit Typography… button in the typography list.  

 

In the opened Typography dialog box, you can change any text object by selecting the object and clicking 

the "Modify" button. The Modify dialog allows adjusting to the following font settings: 

 Font Family 

 Font Style 

 Font Size (in pixels) 

 Add or remove Effects 

 Adjust Character Spacing 
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For the footer text, blocks text, article headline text, and article header text you can also modify paragraph 

settings such as: 

 Alignment 

 Indentation 

 Spacing  
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Font Scale option allows you to change the overall font scale. You can set custom the font scale. Just 

click on the Options… button to get started. 

           

Properties: 

Typography options 

 

Font Scale 

Sets the font scale for all text. The supported values are from 50% to 200%. 

Where 200% means the biggest font scale.  

3. Layout 

The layout tab is where you can quickly change the overall positioning of elements on the page. 
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3.1 Page/Column Layout 

You can quickly change the positioning of the header and navigator bars. Artisteer allows you to place the 

navigator above or below the header or choose not to use a menu bar at all. In addition, if your page will 

have more content, you might want to expand your site into two or more columns. 

 

3.2 Columns 

When a multi-column layout is being used, the Layout Options dialog box displays a set of sliders that 

allows you to set the percentage of the column widths.  

 

Clicking on the "Width Options…" will open the Layout Options dialog box. You can enter the values to 

achieve the desired column width. 
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4. Background 

The background of the page is just as important as the page itself.  You can change the background effects 

to achieve the desired look.   

 

You can choose to have: 

 Background image. Select one of our images or insert your own (click the  

button). 

 Image or Texture. You can insert your own texture template. 

 Glare. You can also insert your own Glare template. 

 Gradient. 

 Overall color of the Background. 

4.1 Adjust Page Background Options. 

Open "Options…" dialog to improve the design of the page background. You can customize:  

 Image or Texture 

 Glare 
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 Gradient 

 

Properties:  

Image or Texture 

 

Texture Repeat 

Sets if/how a background image or texture will be repeated. The supported values: 

 Fill - The background image will be repeated vertically and horizontally 

 Horizontally (Default) - The background image will be repeated horizontally 

 Vertically - The background image will be repeated vertically 

 No repeat - The background-image will be displayed only once. This option 

is not available when “No Texture” is selected in “Image or Texture” list. 

 

Position 

Sets the starting position of a background image. This option is not available when 

“No Texture” is selected in “Image or Texture” list. 

 

Scrolling 

Sets whether a background image is fixed or scrolls with the rest of the page. This 

option is not available when “No Texture” is selected in “Image or Texture” list. 

 

Transparency 

Sets background texture image transparency. The supported values are from 0 to 

100%, where 0% means “without transparency”. This option is not available when 

“No Texture” is selected in “Image or Texture” list. 

 

 

Blend Mode 

Sets how background color and background texture image layers are blended into 

each other. There are 3 options available: 

 Normal - No effect on the underlying layers. 

 Overlay - Blends the two layers together by changing the opacity, darkness, 
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and lightness of the top layer. 

 Soft Light - This blend mode lightens or darkens the image depending on 

the color of the top layer: if the top layer's pixel is dark, then the bottom 

layer's pixel is darkened; if the top layer's pixel is light, then the bottom 

layer's pixel is lightened. 

This option is not available when “No Texture” is selected in the "Image or Texture" 

list. 

 

Glare 

 

Transparency 

Sets glare transparency for the page background. The supported values are from 

0% to 100% where 0% means "without transparency". This option is not available 

if “No Glare” is selected in the Glare list. 

 

Align 

Sets the position of a glare image. Available options are Left, Right, and Center to 

align the glare image left, right, or center respectively. This option is not available 

if "No Glare" is selected in the Glare list. 

 

Gradient 

 

Height 

Sets height for the selected gradient type (the gradient type may be changed in 

Gradient list). The supported values are from 1 to 1000 pixels. This option is not 

available when "No Gradient" is selected in the Gradient list. 

 

Contrast 

Increases or decreases luminosity difference between the starting and ending 

colors in the gradient. This option is not available when “No Gradient” is selected 

in the Gradient list. 

5. Sheet 

The Sheet tab provides the ability to change the overall positioning and look of the sheet or page. You 

might prefer a sheet with rounded edges instead of square edges. You may also want to move the sheet 
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down a bit from the top of the page, put a shadow effect, change the width of the borders, the sheet’s 

background transparency, or the color of the sheet. 

 

5.1 Adjust Sheet Options 

The sheet options can be customized by clicking on the appropriate button in the option list. For example, if 

you want to change the Padding value click on the More Padding… button. 

 

When you open the "Sheet Options" dialog box, you will be able to edit the design of the sheet. You can 

play around with the sheet & shadow parameters as well to achieve the desired result. 
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Sheet parameters include the width of the sheet and its borders, the padding, and the radius values. You 

can also set custom transparency values for the sheet background. Shadow parameters control the size, 

angle and opacity of the shadow as well as its distance from the sheet borders.  Enter the values or drag 

the sliders to the right to increase option values or to the left to decrease them. 

 

Properties: 

Sheet 

 

Width 

Sets the sheet width in pixels. Supported values: 500 px (the minimum width) to 

1500 px (the maximum sheet width).  

 

Top offset 

Sets the top offset for the sheet in pixels. Supported values: 0 px to 200 px, where 

0 px means "no top offset". This option is reset to 0 if “Without Offset” option is 

selected in the Top Offset list. 

 

Padding 

Sets the padding for the sheet content in pixels. Supported values: 0 px to 50 px, 

where 0 px means no padding. This option is disabled when “No Padding” is 

selected in the Padding list. 

 

Radius 

Sets the corner radius of the sheet in pixels. Supported values: 0 px to 200 px, 

where 0 px is equivalent to “No Radius” selected in the Radius list. 

 

Border Width 

Sets border width for the sheet in pixels. Supported values are: 0 px to 20 px, 

where 0 px is equivalent to “No Border” in the Border list. 

 

Transparency 

Sets the sheet transparency. Supported values are: 0% to 100%, where 0% is 

equivalent to “No transparency” selected in the Transparency list. 
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Shadow 

 

Size 

Sets the shadow size for the sheet’s shadow in pixels. Supported values are from 0 

px to 50 px, where 0 px means “without shadow”. This option is disabled when “No 

Shadow” is selected in the Shadow list. 

 

Opacity 

Sets the opacity for the sheet’s shadow. Supported values range from 0% (fully 

transparent) to 100% (fully opaque). This option is disabled when “No Shadow” is 

selected in the Shadow list. 

 

Distance 

Sets the shadow offset in pixels. Supported values: 0 px to 60 px, where 0 means 

"no offset". This option is disabled when “No Shadow” is selected in the Shadow 

list. 

 

Angle 

Sets the shadow’s offset direction. The supported values are from -180° to 180°. 

This option is disabled when “No Shadow” is selected in the Shadow list. 

 

6. Header 

The header tab controls all aspects of the header, including the size, colors, fonts, foreground, and 

background images.  You can use the header tab to make changes to the size and look of the header while 

being able to include background and foreground images. 

 

6.1 Header Layout 

You can make changes to the header layout such as: 

 Header Size 

 Text Block. Here you can choose a Text block position and width. 
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Both layout options can be configured in the General tab of the "Header Options" dialog box. 

 

Properties: 

This section defines the basic properties of the header.  

Note: the Header Options have no effect on layouts without the header selected in Layout > Page Layout 

list. 

General 

  

Height 

Sets the height of the header in pixels. The value can range from 50 to 

500 px. 

 

Text Block 

Sets the width of the text block as a percentage of the header width. The 

range spans from 0% (no text block) to 100% (text block covers the 

entire header). 

6.2 Background 

6.2.1. Background image 

You can choose from a wide variety of professional background images to be used in the header of your 

site. 

 Abstract 

 City 

 Landscape 

 Nature 

 Clouds 
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You can also insert you own background image. Click the From File… button in the Background Photo list 

and select the image you want to use. 

6.2.2. Background Image position 

Feel free to change the position of the picture. The Position dialog box also allows you to apply the following 

header image settings: 

 Resize header to image  

 Resize image to header 

 Use the original image size. 

 

The background parameters can be manually adjusted in the second tab of the "Header Options" dialog 

box. 
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Properties: 

This defines the basic settings of the header background. Depending on the selected image, some 

background options may be disabled. 

 

Background 

 

 

Color Weight 

 

Sets the amount of the base color applied to the header image. The 

base color for the header is selected under Background > Effects > 

Color. Supported values are from 0% to 100%. 

 

 

Color Saturation 

 

Specifies the base color Intensity The values range from 0 (completely 

unsaturated, grey) to 100% (completely saturated, full color intensity). 

Supported values are from 0% to 100%. 

 

 

Blur 

Sets the blur radius ranging from 0 to 30 pixels. The blur effect averages 

all pixels within the specified radius; the larger radius leads to more 

blurring. 

 

 

Blend Mode 

(Enabled only for 'Abstract' 

backgrounds) 

 

Sets how the header image is blended with the header color. This option 

is enabled only for the “Abstract” background images. Supported values 

are: 

Softlight – Lightens or darkens the bottom layer colors depending on the 

colors of the header image.  

Overlay – Blends two layers preserving the opacity, lightness and 

darkness of the bottom layer. 

 Sets a quality level for JPEG compression. The range goes from 0 to 

100%. Better image quality results in larger file size so drag the slider 
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JPEG Quality 

left or right to select an appropriate trade-off between file size and 

image quality. 

6.2.3. Background Image Effects 

You can add visual effects to the background to make your design look even more impressive and unique. 

Header background options include the following effects that can be applied to the header background: 

 Color of the header - If you select “No photo” in the Background photo list the Header will be 

filled with the chosen color.  If you select the background image, this color will be used for 

image colorization. 

 Image Recolor 

 Glare - You can insert your own glare template. 

 Texture - You can also insert your own texture template. 

 Gradient 

 Blur 

 

Properties: 

Effects 

Glare 
Specifies the glare settings for the header background. To enable, 

select any glare from the Header background > Effects > Glare. 

 Specifies the transparency of the glare image. Supported values: 0% 
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Transparency (no transparency) to 100% (fully transparent). 

 

Blend Mode 

Specifies how the glare blends with the underlying layer of the block. 

Options:  

Normal - No effect on the underlying layers. 

Soft Light - Lightens or darkens the image depending on the color of the 

glare Image. 

Overlay - Blends the layers together by changing the opacity, darkness, 

and lightness of the glare Image. 

 

Position 

Specifies the position of a glare Image. Supported values: Left, Center 

and Right. 

 

 

Fit 

Specifies the method of fitting the image into the header area. Options: 

Vertical - resizes the image’s height so that it fits vertically into the 

header area. 

Whole - resizes the image, both vertically and horizontally, to fit 

completely into the header (occupy the entire header area). 

Gradient 
Specifies the gradient settings for the header area. To enable, select 

any gradient from the Header > Background > Effects > Gradient. 

 

 

Contrast 

Specifies the contrast between the starting and ending colors in the 

gradient. The values range from -100 (solid color) to 100% (the most 

gradient contrast). 

 

Angle 

Specifies the angle at which the gradient is applied. The values range 

from -180˚ to 180˚ which allows you to select any desired direction of 

the gradient fill. 

Texture 
Specifies the glow of the foreground object. To enable, use a 

foreground photo on the header. 

 

Transparency 

Specifies the transparency of the header texture. Supported values: 0% 

(no transparency) to 100% (fully transparent). 
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Blend mode 

Specifies how the texture blends with the underlying layers of the 

header. Options: 

Normal - No effect on the underlying layers. 

Soft Light - Lightens or darkens the image depending on the color of the 

texture image. 

Overlay - Blends the layers together by changing the opacity, darkness, 

and lightness of the texture image. 

6.3. Foreground Photo 

This section provides the ability to add a photo that will be complementing your header. You have the ability 

to choose the foreground photo from a variety of professional photos or many different types of subjects. 

You can also insert your own photo. 

6.3.1. Position 

Feel free to change the position of the foreground photo in the Object Position dialog box. Simply drag the 

photo to the necessary place. Also, this dialog allows you to change the size of the photo. Just move the 

slider or click on the “100%” button to apply the full size of the photo. 
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6.3.2. Effects 

You can add visual effects to the foreground photo to make your design look even more impressive and 

unique. Header foreground photo options include the following effects that can be applied to the header 

foreground photo: 

 Recolor 

 Glow 

 Flip 

The foreground photo effects can be manually adjusted on the fourth tab of the "Header Options" dialog 

box. 

 

Properties: 

This specifies the glow of the foreground object. To enable, use a foreground photo for the header. 

6.4. Title 

This section provides the ability to change the headline text and the slogan text of your design.  

Foreground Photo 

 

Glow Size 

Specifies the size of the glow from the edges of the foreground object.  

 

Glow Opacity 

Specifies the glow intensity. Supported values: 0% (fully transparent, invisible) 

to 100% (solid, opaque glow). 
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You can also specify the necessary font options: 

 Color 

 Font Family 

 Font Style 

 Font Size 

 

Clicking the “Font Options…” button opens the Header Logo Name/Slogan dialog box where you can adjust 

the font settings like: 

 Font Family 

 Font Style 

 Font Size (in pixels) 

 Effects 

 Character Spacing 
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6.5. Title Style 

This section provides the ability to change the title style settings to complete your title. The title style section 

includes the following functions: 

 Position - simply drag the title to the desired place: 

 

 Size 

 Align 
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7. Menu 

The Menu tab is used to control the position and appearance of the main navigation menu. It consists of the 

menu bar and the menu items.  It can be implemented as a standard website menu or in the form of tabs or 

menu buttons. 

 

7.1. Menu Styles. 

You can change the overall style of the menu buttons including the shape, coloring, borders and spacing 

between the items. Using the styling option, you can change the following settings: 

 Shape 

 Margin 

 Distance 

 Separator 

There are margin and distance options available for adjustments to the menu layout. 

 

Properties: 

Layout 
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7.2. Menu Bar 

Refine the navigation bar further by choosing the overall gradient, border width, color and fill effect. 

 

The “Menu Options” dialog box allows you to adjust gradient and border settings. Just click on the “Gradient 

Options…” or “More Borders…” button in the appropriate list. 

 

Properties: 

 

Margin 

Specifies the space around the menu. Supported values: 0 to 20 pixels. 

Please note: For the Tabbed Menu the top margins look doubled, as the menu 

is bottom-aligned.  

 

Distance 

Specifies the horizontal distance between menu items. Supported values: 0 to 

30 pixels. 

Menu Bar 

 

Border width 

Specifies the width of the menu borders. Supported values: 0 to 5 pixels. To 

enable, select any border for the menu bar. 

 

 

 

Specifies the contrast between the starting and ending colors in the menu bar 

gradient. Supported values: -100% (solid color) to 100% (the most contrast 
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7.3. Item 

This section provides the ability to choose how individual items of the navigation bar should look when you 

hover over or click on them.  

 

This section includes the following functions: 

 Set the Size, Radius and Gradient values for the menu Items by clicking on the “Item” 

button. 

 Adjust Border settings. 

 Change color and text parameters. 

If the default settings do not meet your needs, you can use the "Menu Options" dialog box to adjust the 

option settings. 

 

Gradient contrast gradient). To enable, select any gradient from the Menu Bar > Gradient list.  
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Properties: 

7.4. Sub Item 

This section covers the ability to control the appearance of items in submenus. You can change the 

following options: 

 Gradient and Size in the sub item list 

 Fill 

 Border 

 Text 

If the default settings don't meet your needs, use the "Menu Options" dialog box to adjust the option 

settings. 

Item 

 

Horizontal padding 

Specifies the horizontal distance between the item text and item borders. 

Supported values: 0 to 50 pixels. 

 

Vertical padding 

Specifies the top and bottom padding of the menu items. Supported values: 0 

to 50 pixels. 

 

Radius 

Specifies the corner radius of the menu item. Supported values: 0 to 100%.  

 

Border width 

Specifies the width of the menu item borders. Supported values: 0 to 5 pixels. 

This option is disabled when the menu items have no borders. 

 

 

Gradient contrast 

Specifies the contrast between the starting and ending colors in the item 

gradient. Supported values: -100 (solid color) to 100% (the most contrast 

gradient). To enable, select any Gradient from the Menu > Item > Gradient list.  
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Properties: 

These will allow you to specify the submenu options. Please note: The options are disabled if “No 

Submenus” is selected in the Sub Item list > Level. Also note that the Gradient contrast option is disabled if 

“No gradient” is selected in the Sub Item list > Gradient. 

 

8. Articles 

The Article tab provides the ability to control the look of the article. You can choose the article shape 

(blockless or in-block), format the text option, or change the article header and footer.  

Subitem 

 

Horizontal padding 

Specifies the horizontal distance in the sub item drop-down list in pixels. 

Supported values: 0 to 50 pixels. 

 

Vertical padding 

Specifies the top and bottom padding of the menu sub items. Supported 

values: 0 to 50 pixels. 

 

Border width 

Specifies the width of the sub item borders. Supported values: 0 to 5 pixels.  

 

Gradient contrast 

Specifies the contrast between the starting and ending colors in the sub item 

gradient. Supported values: -100 (solid color) to 100% (the most contrast 

gradient). To enable, select any Gradient from the Menu > Sub item > 

Gradient list. 
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8.1. Shape 

In this section, you can choose the article content shape (blockless or in-block) and use the styling button to 

change the following style options: 

 Content 

o Margin 

o Text Padding 

 Shape 

o Fill 

o Border 

o Radius 

 Effects 

o Shadow 

 

8.1.1. Shape 

If the default settings do not meet your requirements, you can use the "Articles Options" dialog box to 

customize the settings. To get to the required section of the article options, click on the “More...” button, for 

example “More Padding…” below any list. 
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Properties: 

Shape 

 

Margin 

Specifies the margin of the article content in pixels. Supported values 

are: 0 to 50 pixels. 

 

Padding 

Specifies the padding of the article text in pixels. Supported values: 0 

to 50 pixels. 

 

Radius 

Specifies the corner radius of the in-block content in pixels. Supported 

values: 0 to 40 pixels. 

 

Border  

Width 

Specifies the border width of the in-block content in pixels. Supported 

values: 0 to 10 pixels. 0 corresponds to “Without Border”. This option 

is only available if you use the in-block shape. 

8.1.2. Shadow 

Clicking on the “More Shadows…” button in the styling > Shadow list opens the “Article Options” dialog box 

where you can adjust shadow options. 
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Properties: 

Please note:  The shadow options are available only for the in-block shape. 

Shadow 

 

Size 

Specifies the shadow size of the article block in pixels. Supported 

values: 0 to 20 pixels. 

 

Opacity 

Specifies the shadow opacity of the article block. Supported values 

are: 0 to 100%. 

 

Distance 

Specifies the offset distance of the shadow in pixels. Supported 

values: 0 to 20 pixels, where 0 indicates no offset. 

 

Angle 

Specifies the angle at which the shadow is dropped from the article 

block. Supported values: -180º to 180 º. 

8.2. Text Formatting 

This section allows you to change the text format options like: 

 Margin Left 

 Margin Right 

 Line Height 

 Character Spaying 

 Font Options 

 Align 
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Clicking on the “Font Options…” button opens the article content-text option dialog where you can adjust 

such font settings like: 

 Font Family 

 Font Style 

 Font Size (in pixels) 

 Effects 

 Character Spacing 

 

You can also modify the paragraph setting including:  

 Alignment 

 Indentation 

 Spacing 

Just click on the “More options…” button in the appropriate text formatting list. 
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8.3. Other elements 

This section provides the ability to control the look of the following article elements: 

 Headings 

 Hyperlink 

 Quote 

 Bullets 

 Picture 

 Table 

 

You can change the font options, quote style, bullets picture, table border settings or picture border settings 

to make your article more unique.  
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Clicking on the “Font Options…” button in the appropriate element list (Headings, Hyperlink, and Quote) will 

open the Article Content Option dialog box where you can adjust font and paragraph (for headings and 

quote) settings. 

It is worth mentioning the Bullets elements. You can choose a picture from the variety of included images 

or insert your custom image. You can also change the color of the bullet. 

 

Clicking on the “Bullet Option…” button will open the Article Option Dialog box where you can change the 

offset and re--coloring options of the bullets. 

 

Properties: 

Bullets 

 

Offset 

Specifies the indent between the bullet and the list text. Supported values: 0 to 

20 pixels. 

 

Recoloring 

Specifies whether the bullets should be re-colored. Supported values: Yes and 

No. 
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To finish your list configuration, you can change the font options of the text in the list. Just click on the “Font 

Option…” button and adjust the font and paragraph settings in the Article Content – List dialog box. 

 

8.4. Header and Footer 

You can customize the article header and footer, adjust style, text, and headline by choosing icons from the 

predefined pictures or by using your own images.  

 

You can change the date, author, and edit icons located in the article header section and the category tags 

and comments icons located in the article’s footer. 
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9. Blocks 

Blocks are the individual components that make up the content of the page.  Things located in the blocks 

include links, bookmarks, search boxes and the overall postings of the page. 

 

9.1. Block Styles. 

The block style options allow you to choose how you want blocks to be contained.  Maybe you want the 

content underneath a block to fall within a border or any other number of design combinations. 
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9.1.1. Styling 

The styling option provides the ability to change the block spacing, alter the distance between blocks, or 

make the blocks more rounded by changing the radius value. 

 

Clicking on the “More….” buttons in the styling lists will open the Block Option dialog box where you can 

adjust layout options. 

 

Properties: 

Layout 

 

Radius 

Specifies the radius of block corners. Supported values: 0 to 40 pixels. To 

enable, select any blocked style from the "Block Styles" list. 

 

Block spacing 

Specifies the spacing around blocks in pixels. Supported values: 0 to 40 

pixels. 
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9.1.2. Background 

If your template allows it, you can change the background color and border of the blocks as well as apply 

different effects to your blocks. 

 

Clicking on the “More……” buttons will open a Block options dialog box. 

 

Properties: 

 

Distance 

Specifies the vertical distance between the header and body sections of the 

block. To enable, select any blocked style from the "Block Styles" list. 

Background 

 

Padding 

Specifies the space between the outer borders of the block and the content 

area within the block. Supported values: 0 to 50 pixels. To enable, select any 
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If you selected a template with a shadow effect, the shadow option provides the ability to change size, angle 

and opacity of the block shadow as well as indicate the distance between the shadow and the block 

borders. To accomplish this, just click on the “More Shadow…” button in the Background -> Effects -> 

Shadow list. 

 

blocked style from the "Block Styles" list. 

 

Border width 

Specifies the block border width. Supported values: 0 to 10 pixels. To enable, 

select any blocked style from the "Block Styles" list. 

 

 

Gradient contrast 

Specifies the luminance difference between the starting and ending colors of 

the gradient. Supported values: -100 (solid color) to 100% (the most contrast 

gradient). To enable, select any Gradient from Blocks > Block Styles > 

Background > Gradient list. 

Texture 
Specifies the background texture options. To enable, select any texture from 

Blocks > Block Styles > Background > Texture list. 

 

Transparency 

Specifies the transparency of the background texture. Supported values: 0 

(fully opaque) to 100% (fully invisible). 

 

 

Blend mode 

Specifies how the texture blends with the underlying layer of the block. 

Options: 

Normal - No effect on the underlying layers. 

Soft Light - Lightens or darkens the image depending on the color of the 

texture image. 

Overlay - Blends the layers together by changing the opacity, darkness, and 

lightness of the texture image. 
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Properties: 

You can also alter and specify the shadow options. The options are disabled for no-block styles selected in 

the "Block Styles" list. 

9.1.3. Header 

Each block has an individual header.  You can choose how you want that header to look.  You can change 

the header color as well as the font and color of the text. You can even choose an icon from a variety of 

proposed icons or insert your own custom icon image.  

 

You can add gradient and texture effects to the block header. Both options can be further customized in the 

Block Options dialog. You can also add a custom texture to the block header. 

Shadow 

 

Size 

Specifies the shadow thickness. Supported values: 0 to 20 pixels. 

 

Opacity 

Specifies the shadow opacity. Supported values: 0 (fully transparent) to 100% 

(fully opaque). 

 

Distance 

Specifies the shadow offset in pixels. Supported values: 0 to 20 pixels.  

 

Angle 

Specifies the shadow angle starting from the edges of the block. Supported 

values: -180° to 180°. 
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Clicking on the “Texture Options…” or “Gradient Options…” in the appropriate list will open the Block Option 

dialog box where you can adjust the effects settings. 

 

Properties: 

Header 

 

Border width 

Specifies the width of the block header border. Supported values: 0 to 10 

pixels.  

To enable, select any with-header style from the "Block Styles" list. 

 

Gradient contrast 

Specifies the contrast between the starting and ending colors in the gradient. 

Supported values: -100 (solid color) to 100% (the most contrast gradient). 

To enable, select any gradient from Blocks > Block Styles > Header > 
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9.1.3. Content 

You can adjust the color and style of the block content as well as control the borders, text colors and 

hyperlinks that appear in the blocks. 

 

You can also add gradient and texture effect to the block’s content. Both of these options are available for 

customization. You can also add a custom texture template. 

Clicking on the “Texture Options…” or “Gradient Options…” in the appropriate lists will open the Block 

Option dialog where you can adjust effects and bullets settings. 

Gradient list. 

Texture 
Specifies the settings of the block header texture. To enable, select any 

texture from Blocks > Block Styles > Header > Texture list. 

 

Transparency 

Specifies the transparency of the block header texture. Supported values 0 

(fully opaque) to 100% (fully transparent). 

 

Blend mode 

Specifies how the texture blends with the underlying layer of the block. 

Supported values:  

Normal - No effect on the underlying layers. 

Soft Light - Lightens or darkens the image depending on the color of the 

texture image. 

Overlay - Blends the layers together by changing the opacity, darkness, and 

lightness of the texture image. 
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Properties: 

Content 

 

Padding 

Specifies the space between the content block borders and the content of the 

block. Supported values: 0 to 50 pixels. 

 

 

Border width 

Specifies the width of the content block borders. Supported values: 0 to 10 

pixels.  

To enable, select any style with inner content block from the "Block Styles" list. 

 

 

Gradient contrast 

Specifies the difference in luminance between the starting and ending colors 

in the gradient. Supported values: -100 (solid color) to 100% (the most 

contrast gradient). 

To enable, select any gradient from the Blocks > Block Styles > Content > 

Gradient list. 

Texture  Specifies the settings of the block header texture. To enable select any 

texture from Blocks > Block Styles > Content > Texture list. 

 

Transparency 

Specifies the transparency of the content block texture. Supported values 0 

(fully opaque) to 100% (fully transparent). 

 

 

Specifies how the texture blends with the underlying layer of the block. 

Supported values:  

Normal - No effect on the underlying layers. 
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9.2. Block Content 

This section allows you to change the settings like: 

 

 Margin Left 

 Margin Right 

 Line Height 

 Character Spaying 

 Font Options 

 Link Options 

 Bullets 

You can also modify the font settings of the block content according to your needs. 

Blend mode Soft Light - Lightens or darkens the image depending on the color of the 

texture image. 

Overlay - Blends the layers together by changing the opacity, darkness, and 

lightness of the texture image. 

Bullets Specifies the Bullet Properties. 

 

Offset 

Specifies the indent between the bullet and the list text. Supported values: 0 to 

20 pixels. 

 

Recoloring 

Specifies whether the bullets should be re-colored.  
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Clicking on the “Font Options…” button will open the Article Content-Text options dialog box where you can 

adjust such font settings like: 

 Font Family 

 Font Style 

 Font Size (in pixels) 

 Effects 

 Character Spacing 

 

You can also alter the following paragraph settings:  

 Alignment 
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 Indentation 

 Spacing 

Just click on the “More options…” button in the appropriate text formatting list. 

 

You can also modify link parameters or visited and hovered link font settings just by clicking on the “Font 

options…” button in the appropriate Link list. 

 

 

To complement your Block you can change the bullets parameters. 
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10. Buttons 

The Buttons tab is used to choose the shape and style of the buttons. 

 

Button Styles 

You can select from a wide variety of button styles.  You can choose buttons with more rounded corners, 

something in between, or completely rectangular shape. 

 

Button Format 

You can make finishing touches to the button as well.  
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The button section allows you to change the following options: 

 Shape 

 Gradient 

 Border 

 Shadow 

 Fill Color 

 Border Color 

 Text 

Artisteer provides a variety of button shape templates. Clicking on the “Shape Option…” button in the shape 

list you can adjust the shape settings. You can also adjust some effects like gradient contrast: 

 

 Properties: 

Button 

 

Horizontal padding 

Specifies the horizontal distance between the button caption and button 

borders. Supported values: 0 to 50 pixels. 

 

Vertical padding 

Specifies the vertical distance between the button caption and button borders. 

Supported values: 0 to 50 pixels. 

 Specifies the button corners. Supported values: 0 to 100%.  
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If you add a shadow effect to your buttons you have the possibility to make custom changes in the Button 

Option dialog. Just click on the “Shadow options…” button. 

 

Properties: 

 

Radius 

 

Border width 

Specifies the width of the button borders. Supported values: 0 to 10 pixels.  

 

 

Gradient contrast 

Specifies the contrast between the starting and ending colors in the button 

gradient. Supported values: -100 (solid color) to 100% (the most contrast 

gradient). 

To enable, select any gradient from the Buttons > Button > Gradient list. 

Shadow 

 

Size 

Specifies the blur size of the shadow. Supported values: 0 to 20 pixels. 

 

Opacity 

Specifies the shadow opacity. Supported values: 0 (fully transparent) to 100% 

(fully opaque). 

 

Distance 

Specifies the shadow offset in pixels. Supported values: 0 to 20 pixels.  

 

Angle 

Specifies the angle at which the shadow is cast from the button. Supported 

values: -180° to 180°. 
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To finish the button design, you can change the overall fill of the buttons or change the text settings. The 

text option allows you to change the color of buttons and hovered buttons, as well as adjust font settings. 

 

11. Footer Tab 

The footer tab is used to specify the style of the website’s footer. 

 

11.1 Footer Styles 

The footer options include the following effects that can be applied to the footer: 

 Color 

 Gradient 

 Texture 

 Align 

 Text Padding 

 Text font 

 Change Hyperlinks font 

 RSS icon  
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In the Footer Options dialog box you can customize effects applied to the footer. 

 

Properties: 

Options 

 

Padding 

Specifies the padding of the footer’s text in pixels.  Supported values: 0 to 

50 pixels, where 0 means “No Padding”. 

 

Gradient Contrast 

(Available if a Gradient  

is used ) 

Use to increase or decrease the luminosity difference between the starting 

and ending color of the gradient. 

 

Texture Transparency 

(Available if a Texture 

 is used )  

Specifies the texture transparency. The supported values are from 0 (fully 

opaque) to 100% (fully transparent, invisible texture).  

 

Texture Blend Mode 

(Available if a Texture 

 is used ) 

Specifies the blend mode applied while mixing the background color and 

texture image: 

Normal - No effect is applied while mixing layers; 

Overlay - Two layers are blended by changing the opacity, darkness, and 

lightness of the texture. 

Soft Light – Changes the colors in the footer image depending on the color 
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of the top layer. 
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Troubleshooting 

".NET Framework is not installed" error. 

Artisteer requires .NET Framework 2.0 or higher to be installed on your computer.  

Solution 

Microsoft NET Framework can be obtained and installed from:  

http://www.microsoft.com/downloads/details.aspx?familyid=79BC3B77-E02C-4AD3-AACF-

A7633F706BA5&displaylang=en 

 

PHP Fatal error in WordPress  

PHP Fatal error: Only variables can be passed by reference in ...\wordpress\wp-includes\query.php on line 

2548. This occurs when the posts page is set to a static page different from the homepage: 

Solution 

You can either upgrade your PHP version or use the following workaround:  

Open the query.php and replace this code line: 

$this->queried_object = & get_page(get_option('page_for_posts')); 

With these two lines: 

$tmpPageVariable = get_option('page_for_posts'); 

$this->queried_object = & get_page($tmpPageVariable); 

http://www.microsoft.com/downloads/details.aspx?familyid=79BC3B77-E02C-4AD3-AACF-A7633F706BA5&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=79BC3B77-E02C-4AD3-AACF-A7633F706BA5&displaylang=en
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Glossary 

CMS  

A Content Management System (CMS) is a software application designed to create, edit, publish and 

manage website content using a simple browser-based interface. The content may include text, photos, 

electronic documents, music, video and other type of computer files. These systems usually provide a 

number of ready-made solutions and standard templates for most common applications.  The main 

advantage of a CMS is that it requires almost no technical skills or knowledge to create the website and 

manage its content. 

Blog 

A blog (short for "Web log") is a special type of web site with a series of entries usually posted to a single 

page in reverse-chronological order. Blogs are often maintained by an individual and represent the 

personality of the author, provide diary-type commentary, links to articles on other Web sites, descriptions 

of different events and social issues, or include other material such as graphics or video.  

WordPress 

WordPress is an open source blog publishing application. It is an advanced blogging tool with a focus on 

aesthetics, web standards, and usability. The official WordPress website is http://wordpress.org. 

Joomla 

Joomla is a free, open source content management system written in PHP. It is used for publishing and 

managing content on the web and intranets and allows you to build powerful online applications.  

The official Joomla website is http://www.joomla.org. 

Drupal 

Drupal is a free software package that allows an individual or a community of users to easily publish, 

manage and organize a wide variety of content on a website. It is an open-source project written in PHP 

and distributed under the GPL. The official Drupal website is http://drupal.org. 

http://wordpress.org/
http://www.joomla.org/
http://drupal.org/
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Visual Studio 

Visual Studio is an integrated development environment (IDE) from Microsoft. The official website is 

http://www.microsoft.com/visualstudio/en-us/default.mspx. 

CodeCharge Studio 

CodeCharge Studio (CCS) is a Rapid Web Application Development Tool from YesSoftware Company. It is 

a software suite designed for visually creating dynamic database-driven Web applications. The official 

company website is http://www.yessoftware.com. 

HTML 

HyperText Markup Language (HTML) is the predominant markup language for web pages which provides a 

set of markup symbols or codes to specify the structure of documents for retrieval across the Internet using 

Web browser programs. HTML is written in the form of tags, surrounded by angle brackets. The document 

can contain links, headings, paragraphs, lists, and text supplemented with interactive forms, embedded 

images, and other objects.  

CSS 

Cascading Style Sheets (CSS) is a style language that defines the presentation of a document written in a 

markup language.  CSS controls the overall layout, text size, style, and formatting and other design 

properties to let developers separate content from design. 

RGB 

RGB stands for the three primary colors of light: red, green, and blue. The combination of these colors in 

different proportions produces any color in the visible spectrum. The RGB system is used for representing 

colors on a computer display. 

HSL 

HSL stands for Hue, Saturation, and Lightness. It is a method for describing colors as they are perceived by 

the human eye. HSL is considered a more intuitive way of dealing with color than RGB.  

http://www.microsoft.com/visualstudio/en-us/default.mspx
http://www.yessoftware.com/
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Hue corresponds to the actual color, saturation corresponds to the intensity, and luminosity corresponds to 

the lightness of the color. 


